Настройка MikroTik на VPS

В данной статье рассмотрим, как установить и настроить MikroTik RouterOS на VPS.

1. Сначала посмотрим в конфигурационном файле IP-адрес VPS и её шлюза. Сохраним их куда-нибудь, они понадобятся в конце. Команда отличается в зависимости от операционной системы VPS. Смотрите лучшие VPS со своим ISO-образом, на нашем сайте.

Для семейства Ubuntu/Debian:

cat /etc/network/interfaces

Для Centos:

cat /etc/sysconfig/network-scripts/ifcfg-eth0

Как посмотреть IP-адрес и шлюз VPS с помощью консоли

2. Установим утилиту unzip, она нам понадобится для распаковки скачанного образа. В данном примере используется ОС Ubuntu, команда для установки:

apt-get install unzip

Установка утилиты unzip с помощью консоли

3. Монтируем временный каталог для образа диска и переходим в него.

Команды:

mount -t tmpfs tmpfs /tmp
cd /tmp

Затем качаем образ диска, команда:

wget https://download.mikrotik.com/routeros/7.2.3/chr-7.2.3.img.zip

Как скачать образ диска на VPS с помощью консоли

Ссылку для wget берем с официального сайта: https://mikrotik.com/download, раздел Cloud Hosted Router Raw disk image.

4. Распаковываем скачанный образ и проверяем, какое имя носит диск VPS.

Команды:

unzip chr-7.2.3.img.zip
fdisk -l

Распаковка скачанного образа на VPS с помощью консоли

В данном примере диск имеет имя /dev/vda

5. Заменяем содержимое диска VPS содержимым образа.

Команда:

dd if=chr-7.2.3.img of=/dev/vda bs=4M oflag=sync

Загрузка содержания образа на VPS с помощью консоли

и перезагружаем VPS командами:

echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger

6. Так как мы перезаписали диск, по SSH мы подключится уже не сможем. Подключаемся по VNC и входим с логином admin и пустым паролем. Можем ознакомиться с лицензионным соглашением.

Подключение к VPS по VNC

Как подключится к VPS по VNC

Далее от нас потребуют сменить пароль.

7. Настроим сеть, чтобы можно было работать с VPS через SSH или Web-интерфейс. Тут используем сохраненные нами в первом шаге IP VPS и шлюза. Если Вы их вдруг не сохранили, то может узнать их в поддержке Вашего хостинга.

Вводим команды:

/ip/address add address=xxx.xxxx.xxx.xxx/yy interface=ether1
/ip/route add gateway=zzz.zzz.zzz.zzz

xxx.xxxx.xxx.xxx/yy и zzz.zzz.zzz.zzz меняйте на IP и шлюз Вашей VPS.

IP и шлюз VPS

Далее проверим доступность сервера Google c VPS командой: ping 8.8.8.8.

Как проверить доступность Google с VPS

Пинг есть, значит сеть настроена корректно и мы можем подключится по ssh или войти через браузер, вписав в адресной строке IP-адрес VPS с пользователем admin и заданным нами паролем.

Вход в MikroTik через браузер

Панель Mikritik RouterOS

Смотрите подборку топ VPS с SSD, на нашем сайте.

Комментарии ()

    Последние отзывыpic


    cloud4box.com

    Написать отзыв

    Александр Литвинов, 30 января 2023 оценил

    Был удивлен разнообразием услуги и их стоимостью, сравнивал цены с другими конкурентами и цены везде были разные. Либо слишком зав...


    Coopertino.ru

    Написать отзыв

    Толя Архипов, 29 января 2023 оценил

    Купил недавно тут вдс сервер. Техподдержка помогла перенести файлы за несколько часов, без проблем для сайта. также хотел бы отмет...


    zomro.com

    Написать отзыв

    Ангелина, 25 января 2023 оценил

    Стабильность в работе- самое важное для моего бизнеса. За все время сотрудничества не было ни одного падения сайта или других проб...


    Handyhost.ru

    Написать отзыв

    Олег, 20 января 2023 оценил

    Привет, хотелось поблагодарить ребят за доброкачественный хостинг. Перенесли сайт с одного хостинга на другой , настроили ВПС, и с...


    ihor.ru

    Написать отзыв

    Андрей Попов, 20 января 2023 оценил

    Ihor хостинг не дорогой vpd KVM SSD Start (1 СPU/512 MB RAM/5 GB SSD) EU VM6 в Финляндии. Брал для vpn, пользуются 10 человек, ни ...


    новые Статьи

    Установка PostgreSQL на VPS c Ubuntu
    Установка Redmine на VPS c Ubuntu
    Сброс root пароля MySQL на VPS
    Установка Mosquitto на VPS
    Установка Mosquitto на VPS

    30 декабря 2022

    Установка Docker на VPS и работа с ним
    Читать все статьи